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Shure Update Utility
Shure Update Utility

Shure Update Utility
The Shure Update Utility (SUU) is an application used to update firmware for Shure devices. The application downloads new 
firmware versions and stores them locally on the computer. The updated versions are then available to send to multiple net­
worked devices at the same time.

Additionally, the Update Utility enables software updates from Shure software applications such as Wireless Workbench .

About Firmware
Firmware is embedded software in each device that controls its functionality. Periodically, new versions of firmware are devel­
oped to incorporate additional features and enhancements. To take advantage of these improvements, new versions of the 
firmware can be downloaded and installed using the Shure Update Utility (SUU) application.

Firmware Versions and Compatibility
The firmware of all Shure devices has the form of MAJOR.MINOR.PATCH (e.g., 1.2.14). To ensure interoperability, all compo­
nents from the same model family (including transmitters) should be updated to the same MAJOR and MINOR firmware ver­
sion numbers (e.g., 1.2.x).

Quick Overview
The following is a quick overview of the SUU application interface. See Interface Description for more details on each .

① Check for Updates but­
ton

Download new firmware versions to your computer.

®
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② Update Devices Tab

Displays connected Shure devices, their current firmware version, and the latest firmware on 
the computer. Use the colored dot in each row to quickly check firmware status of each de­
vice:

Green: Device is up to date with latest version on the computer
Yellow: A newer version is available on the computer
Red: The device requires a firmware update to properly function

③ Firmware Tab Displays all firmware versions downloaded to the computer.

④ Send Updates Button Updates the selected devices with new firmware.

Download the Application
Download the Shure Update Utility from the Shure website: https://www.shure.com/en-US/products/software/
shure_update_utility.

https://www.shure.com/en-US/products/software/shure_update_utility
https://www.shure.com/en-US/products/software/shure_update_utility
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Background Updates for other Shure Applications
The SUU supports updates to other Shure software applications, such as Wireless Workbench . When you check for updates 
from a Shure application, the SUU facilitates the update process in the background as it connects to the Shure server to find 
new releases.

Updating the SUU Application
Important: Before updating the application, make sure all firmware updates have completed, as the update can interrupt the 
transfer of firmware to devices.

Open the Shure Update application on the computer that is connected to the Internet.
Go to the Help menu and select Check for Shure Update Utility Updates.

Your web browser will direct you to the Shure website where the latest version of the Shure Update Utility is hosted. 
Select the appropriate version for your computer. Your download will automatically start.

Find the .zip file in your computer's Downloads folder and extract the contents.
Open the file and follow the prompts to remove the existing application and install the latest version of the SUU.

®



Shure Incorporated

6/19

1.
2.
3.

Update Device Firmware
Use the Shure Update Utility (SUU) application to download new versions of firmware from the Shure web server and upload 
them to devices.

Note: See Updating Portable section for Shure devices that don't connect directly to a computer, such as a wireless handheld transmitter.

Download Firmware to the Computer
Download the latest firmware versions from Shure using the SUU.

Connect the computer to the internet.
Open the SUU application.
Click on the Check for Updates... button to view new firmware versions available to download. When the computer al­
ready has the latest versions, the No Updates Found message displays.
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Select the desired versions and click the Download button. The new downloads will be added to the Firmware tab, mak­
ing them available to install on the device hardware.

Tip: Select All to download all new firmware.

Connect Shure Devices to the Computer
Shure devices connect to a computer using standard networking practices. Follow these guidelines for the most reliable con­
nection:

Connect devices in a "star" network topology (avoid daisy-chained connections)
Devices must be set to same subnet mask
Use only one DHCP server per network
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• Turn off other computer network interfaces not used to connect to the Shure device (including WiFi)

Connection Examples
① Multiple Devices to a 
Switch

Use a DHCP-enabled switch to connect multiple devices in a star configuration

② Device Directly to a 
Computer

Connect the Ethernet or USB port on the Shure device to the computer

Select the Computer's Network Interface
Choose the computer's network interface card (NIC) that the application uses to communicate with Shure devices. A wired net­
work connection is required when updating a device's firmware.

Select the network card that is on the same subnet as the devices connected to your computer. To verify they are the same, 
open the Shure Device Discovery application, which displays all Shure network devices connected to the computer. The IP ad­
dresses of the desired devices should match the NIC selection in the SUU.
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Upload New Firmware to the Devices
Push the updated firmware from the computer to the connected devices. Wait until the update processes is complete before 
turning off or disconnecting any devices.

Open the Update Devices tab to view all Shure devices connected to the computer.
Select each device that will receive a firmware update.

Select a firmware version for each device under the Version to Install column. The newest version downloaded to the 
computer is selected for the update by default, though you can use an older version by double-clicking and selecting 
from the drop-down.

Begin the update by selecting the Send Updates... button. The devices are not available for use during the update 
process.
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Close out of the window once the process is complete.

Updating a Portable Device
Firmware for portable Shure devices, such as transmitters or receivers, is either updated directly through the SUU, or via IR 
sync with a networked device. The networked device hosts a firmware package for the supported portable device, which is 
transferred over dedicated IR ports on both devices.

Note: Exact steps may vary per device, see the user manual for exact details.

For best results, ensure the same firmware version is uploaded to all components of the system.

Connect the networked device to the computer. The networked device hosts a firmware package for the supported 
portable device.
Open the Update Devices tab in the Shure Update Utility.
Scroll to the networked device and select the firmware package for the portable device.
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Tip: For best results, ensure the same firmware version is uploaded to all components of the system.

Select Send Updates... to send the update package to the host device.
Navigate to the portable firmware update screen on the host device. (Varies per model.)
To upload the new firmware, align the IR port of host device with the IR port of the portable device.

Start the firmware transfer and hold the portable device in front of the IR port of the host device. The progress will dis­
play on the front panel of the host device.
For updates sent through a networked charging station, ensure the station is connected to the computer, both are con­
nected to the same network, and all portable devices are docked securely. Then, select the device in the SUU and click 
Send Updates… to deliver the firmware package through the host device to the portable device.



Shure Incorporated

12/19

9.

•

•

•

•

•
•
•

The portable device may reboot after receiving the new firmware.

CAUTION! Do not interrupt the power source from the device while it is rebooting.

Interface Description
Control Bar
① Check for Updates Displays new firmware versions available to download to the computer.

② View Menu

Event Log: Displays time­stamped events regarding downloading firmware and updat­
ing devices.
Release Notes: Links to the Shure web site to provide details on new features, improve­
ments and additional notes for each firmware version.

③ Tools Menu

Check for Updates: Displays new firmware versions available to download to the com­
puter.
Preferences: Customize update settings and select the computer's network interface 
card (NIC) used to update the devices.

④ Help Menu
Launches the Help document for the application.
Download new versions of the SUU application.
View the current application version.
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Update Devices Tab

① Device List

Displays all Shure devices by model that are networked to the computer. Device IDs are 
customizable from the device's control software.

Tip: Hover over a device's Device ID to view its IP address, and right-click to copy it.

② Current Version

The firmware version currently installed on the device. The colored circle indicates the status 
of the firmware:

Green: Device is up to date with the latest firmware version that is downloaded to the 
computer.
Yellow: A newer firmware version has been downloaded to the computer and is avail­
able to upload to the device.
Red: The device requires a firmware update for proper functionality.

③ Version to Install
Drop-down window enables the selection of any firmware version that has been downloaded 
to the computer. A dash (-) appears until the device is selected to receive an update.

④ Select Checkbox Selects or deselects the device to receive a firmware update.

⑤ Select All/None Selects or deselects all devices in the Device List to receive a firmware update.

⑥ Send Updates Button Updates the selected devices to the specified firmware versions.
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Firmware Tab

① Firmware List

Displays each firmware version downloaded to the computer. Right­click for the following op­
tions:

Export the firmware version as a .pack file
Delete the firmware version from the computer
View version release notes on the Shure website

Tip: A blue dot indicates that the version has been recently downloaded.

② Import Button Imports firmware versions from a local file or an external hard drive to the SUU firmware tab.
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Preferences
Go to Tools > Preferences to adjust application settings.

Updates

Use the Updates tab to customize the workflow of the application:

Enable background check to automatically find new firmware updates from the Shure 
web server
Select all new firmware versions when checking for updates
Select all discovered devices when sending updates

Network
Use the Network tab to select the computer's network interface controller (NIC) to be used 
by the Update Utility. Firmware updates are only supported via a wired interface connection.

Log Rotation Adjust the number of event log files stored by the computer.
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Troubleshooting
Before troubleshooting, ensure a reliable network connection and constant power supply. Follow these guidelines when trou­
bleshooting an issue:

Power on all devices
Connect the computer and devices to the same network and set to the same subnet
Turn off other network interfaces not used to connect to the device (including WiFi)
Check that firewall settings are not blocking the Shure Update Utility
Check that DHCP server is functioning (if applicable)

Additional Resources
For additional Troubleshooting assistance or further information on complex installations, contact Shure to speak with a support 
representative. In the Americas region, call Systems Support group at 847-600-8541. For users in other locations, go to 
www.shure.com to find support contact for your region.

Repairing a Failed Firmware Update
If an error occurs during the update process, a recovery file is generated to prepare the device for a normal firmware update 
that will restore functionality.

Use the Repair Corrupt Devices button that appears if an update fails.

Upload recovery firmware by selecting Repair Corrupt Devices. Close the window when the recovery procedure com­
pletes.
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2. The recovered device will display in the Update Devices tab with a red dot, indicating that a firmware update is re­
quired.



Shure Incorporated

18/19

3. Perform a normal firmware update to restore device functionality.

Unavailable Device
The SUU prevents a device from updating when it is flagged as unavailable in the Update Devices tab. The event log contains 
more details. To open the event log, choose View > Event Log.
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